Start a new topic

command tasks greyed out

I did something, not sure what at this point, that caused the command tasks option in the context menu to become greyed out.I tried reinstalling royalts, but the issue remained. Any idea what I did that might have caused the command tasks menu to be greyed out?

1 person has this question


can you try to reset the configuration file by renaming code4ward.RoyalTS.UserPreferences.config file in %appdata%\code4ward while Royal TS is closed. After renaming the file, start Royal TS and see if the issue is still there.



hmm. that didn't work. I even tried uninstalling and then completely removing the remainder of the %appdata%\code4ward directory, then reinstalling, but it still didn't fix it. I even tried creating a new personal document and it does the same thing on the new entries in the new document.

Can you verify if the Application document's task folder has all the tasks in it?

I have the same problem. Reinstalled and renamed the user preferencefile. Im new with this application and it have never worked. Looks exaclty the same for me.



Can you check in the Navigation panel the Application document's Task folder and see if the command tasks are marked as favorites?

I didnt realize that i had to create my own commands. I thought premade commands came with the product. It works now since i create my own. Thanks.

Royal TS comes with a set of pre-configured commands (under Applications -> Tasks). Should a user delete those commands by mistake, renaming the code4ward.RoyalTS.UserPreferences.config file in %appdata%\code4ward (while Royal TS is closed!) will cause Royal TS start with a fresh configuration file and create those tasks again. Not sure why that didn't happen in your case. Any chance Royal TS was still running when you renamed the file?

Found it. All sorted out. Thatnks.

Great to hear that!

Hi. I have the exact same problem and can not fix it with removing the configuration file or by creating a own task in my own document. How to solve this issue now?


after you started with a new configuration file, can you verify if all the Tasks under Application -> Tasks are marked as Favorite? If not, can you mark them as Favorite (using right-click or the properties)?

Let me know if this helps.


Hi Stefan. Thanks. You are right, the tasks must be marked (starred) as favorite, That seems to be new now. a suggestion would be to mark the default tasks as favorite by default since that is what the users had in the past.

Glad that helped. This is actually a bug right now. In the next release we will make sure that the newly created tasks are also marked as favorites.

Thanks for confirming!

Login or Signup to post a comment