Start a new topic
Solved

prevent Ctrl-Shift capture in Royal TSX

I'm using Royal TSX 3.3 on MacOS 10.13.6 and when I RDP into a Windows VM (I've tested against Win7 SP1 and Win10 1803), it looks like something is intercepting/overriding the Ctrl-Shift key sequence.


Repro Steps:

==========

  1. RDP into a Windows VM
  2. press Windows key
  3. type cmd
  4. right click on Command Prompt, select Pin to Taskbar
  5. hold down Ctrl-Shift and left click on the pinned cmd icon

Expected Behavior:
===============
UAC prompt opens to launch elevated cmd.exe (or elevated cmd just launches if UAC is disabled).

Observed Behavior:
===============
The menu that loads is the same behavior that occurs normally in Windows when you press Alt-Shift and right-click on a taskbar icon (if multiple instances of cmd are already running, you will see a menu with the options: Cascade, Show windows stacked, Show windows side by side, Restore all windows, Minimize all windows, Close all windows).

I do not have a DefaultKeyBinding.dict configured, nor do I have a keymapping app running.  If I use the Microsoft Remote Desktop app (10.1.8) from the same Mac, I get the expected behavior (same as when logged physically into a Windows system).

Is there a way to prevent the Ctrl-Shift key binding from being intercepted in RDP sessions from Royal TSX?  

Thanks!


The Expected Behavior also occurs in Royal TS 4.2.61424.10000 from a Win10 x64 Pro 1803 box.

Hi Tony,


in Royal TSX you can make use of control+shift+click inside remote sessions by disabling "Preferences - Connection Types - Remote Desktop - Plugin Settings - Convert control+shift+click to right-click".


Hope that helps!


cheers,

felix


1 person likes this
Login or Signup to post a comment