Start a new topic
Solved

MremoteNG confcons.xml no longer importing

Hello everyone,


Since my MremoteNG was upgraded to 1.75 I stopped being able to import the connection file on RoyalTS, now is always asking for a password even if the file is not password protected.


I believe this is because the files created by MremoteNG on 1.75 now have a default encryption, however it shouldn't ask for a password.


Comparing the header of the xml in the file we can see the versions are different:


Older: 

<Connections Name="Connections" Export="False" Protected="wqWuEiIZkwmX/+38HoG4RRYLYRa5Vkai/lnHzvPgfWUuOPXRAotKjHp8Rzze9f3R" ConfVersion="2.5">


Newer:

Connections Name="WTW" Export="False" EncryptionEngine="AES" BlockCipherMode="GCM" KdfIterations="1000" FullFileEncryption="False" Protected="VztR3muOByI4MtcAmE43OzxK9yP11pMh85j4PQsH5aXLk6w8xWhaUQTLE5MbxEKi9MQZAh63VoPsmraZCSOq" ConfVersion="2.6">


Has anyone else facing the same issue?

Is there any possible way around this?


Thank you in advance.





Hi,


it seems that mRemoteNG changed their encryption algorithm and is now dependent on BouncyCastle (an open source encryption library). The next release of Royal TS will allow you to import mRemoteNG 1.75 files but the passwords will be skipped and has to be entered again. We are looking into ways to get BouncyCastle into Royal TS without being dependent of the whole library. This would further increase the download size of Royal TS.


Regards,
Stefan

Hello Stefan,


Those are great news, I don't mind having to retype all the passwords so please RoyalTS do it :)


Do you have any idea when the new release will be coming out?


Cheers,

The new version was released last week:

https://www.royalapplications.com/ts/win/download


Regards,
Stefan

Hello Stefan,


Thank you for letting me know, do you know if this new version is going to be made available as an upgrade or do I need to uninstall download and install again?


Regards,

NF

The MSI package will automatically uninstall the previous version. Simply launch the MSI and let the installer do its job ;)

That is amazing, I have installed the most recent version and I can confirm the import now works.


Cheers,


NF

Glad to hear that! Thanks for confirming the import is working again (well, at least without the passwords).


Regards,
Stefan

Hi Stefan,


by when we can expect this update in MAC ?

Hi,


the current version of Royal TSX for macOS should have the same fix already. If this still is not working for you, please open a support ticket.


Thank you!

Login or Signup to post a comment