Start a new topic


We recently started using Royal TS and my navigation pane is starting to fill quite nicely.

Unfortunately the more objects I add the sluggisher the scrolling gets when using the mouse wheel. When I  grab the scroll bar and yank it up and down scrolling works perfect.

Is this a common issue?

Hi Manuel,

this may be related to "Pixel Scrolling" (which can be turned off). Go to View -> Options -> User Interface

In the tabs Navigation and Lists you will find a checkbox "Enable Pixel Scrolling". Uncheck them and see if it performs better.


Thanks for the quick reply!

I tried disabling pixelscrolling but didn't notice any improvement.

Can you provide more information about your setup? How many objects are in your document(s) and what exactly means sluggish? For me scrolling with the wheel feels responsive and smooth but I can understand that this is in the eye of the beholder.

At the moment I have 5 Documents opened. Each doc contains around 6 folders and 30 Objects.

Describing sluggish is hard (especially in English):

  • I have a Logitech mouse which I can switch from "clicky" scroll to "free" scroll.
  • When the wheeel is set to "clicky" and I scroll step by step it's okay, I would say.
  • When I really spin the wheel to quickly get all the way down or up the list, it doesnt scrolll at all until the wheel slows down enough, especially when I switch to "free" scroll.

This seems to be related to the logitech mouse or its driver. In my case I have a document with approx. 500 objects and even when I expand everything, it scrolls very smooth. Any chance you can test this with a standard mouse using built-in drivers?

I think you misunderstood:

It's a standard Mouse and drivers - the "switch" I mentioned to turn on free scroll is a physical one.

nothing fancy, nothing special

I see. Well, I'm not sure what's going on here as I'm not able to repro the issue on my side. Can you repro the issue on a different computer as well?

Login or Signup to post a comment