Start a new topic

Right Shift Key issue

Just installed RoyalTS. When I'm RDC'd into a machine, my right shift key doesn't work. The left one works just fine. Filter/sticky keys is not turned on.


Is there a setting for this somewhere? I've looked around and couldn't find one so far.


Hi,


can you check if you have enabled Deep Keyboard Hooks in View -> Options -> General?


Regards,
Stefan

It was disabled. I've turned it on and restarted RoyalTS, however my right shift key still doesn't work when remoted in. The left shift key still works.

That's strange. Can you download and try Microsoft's RDCM:

https://www.microsoft.com/en-us/download/details.aspx?id=44989


Let me know if you also see the issue there.


Regards,
Stefan

I do not see the issue with RDCM, the right shift key works just fine.

That's really weird. I have no idea why this wouldn't work in Royal TS. We're using the very same ActiveX control which ships with Windows. Can you try to rename the file %appdata%\code4ward\code4ward.RoyalTS.UserPreferences.config while Royal TS is not running and start Royal TS. This will create a new config file.

Closed RoyalTS, renamed the config file, restarted RoyalTS, saw the new config file created...


Same problem still.

Really strange. Did you also create a new connection from scratch after the new config file was created. Maybe some keyboard layout issue in the RDP connection config in Royal TS (under Advanced / Input)? We haven"t got any other reports like this. Can you repro the issue on a different PC? Any chance some sort of tool/software on your PC interferes in a strange way with Royal TS?
Login or Signup to post a comment